Back to Topics Directory
Topic Hub

#json-parser (30 Repositories)

Ranked open-source repositories tagged with #json-parser, scored by pull request acceptance likelihood and maintainer engagement velocity.

Topic Avg Merge Rate

26.6%

Avg Review Latency

23.5h

Filter by language

30 repositories tagged #json-parser

A TierRust 551

pydantic/jiter

Fast iterable JSON parser.

52.6%
Merge Rate
2h
First Review
100%
1st-Timers
6
Maintainers
A TierRuby 783

ruby/json

JSON implementation for Ruby

75.0%
Merge Rate
4h
First Review
75%
1st-Timers
2
Maintainers
A TierC++ 50.8k

nlohmann/json

JSON for Modern C++

57.8%
Merge Rate
-
First Review
55%
1st-Timers
40
Maintainers
A TierC++ 24.4k

simdjson/simdjson

Parsing gigabytes of JSON per second : used by Facebook/Meta Velox, the Node.js runtime, ClickHouse, WatermelonDB, Apache Doris, Milvus, StarRocks

47.0%
Merge Rate
-
First Review
50%
1st-Timers
16
Maintainers
B TierJava 4.4k

alibaba/fastjson2

🚄 FASTJSON2 is a Java JSON library with excellent performance.

27.4%
Merge Rate
1h
First Review
21%
1st-Timers
125
Maintainers
B TierJavaScript 1.2k

uhop/stream-json

A micro-library of stream components for building custom JSON and JSONC processing pipelines with a minimal memory footprint — parse, filter, and transform JSON far larger than available memory with a SAX-inspired token API, on Node.js or Web Streams.

34.5%
Merge Rate
2d
First Review
100%
1st-Timers
1
Maintainers
B TierC++ 511

beached/daw_json_link

Fast, convenient JSON serialization and parsing in C++

85.7%
Merge Rate
12d
First Review
100%
1st-Timers
0
Maintainers
B TierScala 544

argonaut-io/argonaut

Purely functional JSON parser and library in scala.

92.3%
Merge Rate
-
First Review
100%
1st-Timers
0
Maintainers
B TierJavaScript 251

fastify/secure-json-parse

JSON.parse() drop-in replacement with prototype poisoning protection

100.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
B TierC++ 26.6k 6 GFIs

google/flatbuffers

FlatBuffers: Memory Efficient Serialization Library

5.3%
Merge Rate
4d
First Review
3%
1st-Timers
46
Maintainers
B TierC 1.5k

kgabis/parson

Lightweight JSON library written in C.

33.3%
Merge Rate
<1h
First Review
0%
1st-Timers
0
Maintainers
B TierSwift 22.9k

SwiftyJSON/SwiftyJSON

The better way to deal with JSON data in Swift.

20.0%
Merge Rate
9d
First Review
0%
1st-Timers
2
Maintainers
B TierJavaScript 187

sundegan/JsonStudio

A fast, modern desktop JSON app built for daily development. The all-in-one workspace for every JSON task, designed to redefine your workflow efficiency.

66.7%
Merge Rate
2d
First Review
0%
1st-Timers
1
Maintainers
B TierPython 1.7k

simplejson/simplejson

simplejson is a simple, fast, extensible JSON encoder/decoder for Python

100.0%
Merge Rate
2h
First Review
0%
1st-Timers
1
Maintainers
D TierGo 5.6k

buger/jsonparser

THE fastest alternative JSON parser for Go that does not require schema

0.0%
Merge Rate
14h
First Review
0%
1st-Timers
1
Maintainers
D TierC# 343

zanders3/json

A really simple C# JSON Parser in 350 lines

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierC 297

scottcgi/MojoJson

A simple and fast JSON parser.

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierJava 25.6k

alibaba/fastjson

FASTJSON 2.0.x has been released, faster and more secure, recommend you upgrade.

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierGo 15.6k

tidwall/gjson

Get JSON values quickly - JSON parser for Go

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierOBObjective-C 246

netyouli/WHC_Model

iOS平台高效转换引擎json->model,model->json,model->Dictionary,支持模型类继承其他模型类,支持指定路径转换,不区分json的key和模型属性名称大小写,自动处理json中null

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierJava 432

simdjson/simdjson-java

A Java version of simdjson, a high-performance JSON parser utilizing SIMD instructions

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierElixir 2.0k

devinus/poison

An incredibly fast, pure Elixir JSON library

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierGo 4.9k

mailru/easyjson

Fast JSON serializer for golang.

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierZig 175

EzequielRamis/zimdjson

Parsing gigabytes of JSON per second. Zig port of simdjson with fundamental features.

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierJava 138

ifeilong/feilong

让Java开发更简便的工具库

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierScala 971

spray/spray-json

A lightweight, clean and simple JSON implementation in Scala

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierGo 2.5k

valyala/fastjson

Fast JSON parser and validator for Go. No custom structs, no code generation, no reflection

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierSwift 187

objecthub/swift-dynamicjson

Framework for representing, validating, querying, and manipulating generic JSON values in Swift 6. Supported are standards such as JSON Text Sequences (RFC 7464), JSON Pointer (RFC 6901), JSON Path (RFC 9535), JSON Patch (RFC 6902), JSON Merge Patch (RFC 7396), and JSON Schema.

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierJava 107

landawn/abacus-common

Release the power in Java programming

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
D TierSwift 501

nixzhu/Coolie

Coolie(苦力) helps you to create models (& their constructors) from a JSON file.

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
Best Json-parser Open Source Repositories & C-Rank™ | GetMerged