Back to Topics Directory
Topic Hub

#cbor (15 Repositories)

Ranked open-source repositories tagged with #cbor, scored by pull request acceptance likelihood and maintainer engagement velocity.

Topic Avg Merge Rate

53.5%

Avg Review Latency

31.6h

Filter by language

15 repositories tagged #cbor

A TierC 406

PJK/libcbor

CBOR protocol implementation for C

83.3%
Merge Rate
4h
First Review
100%
1st-Timers
1
Maintainers
A TierJava 348

FasterXML/jackson-dataformats-binary

Uber-project for standard Jackson binary format backends: avro, cbor, ion, protobuf, smile

57.6%
Merge Rate
-
First Review
100%
1st-Timers
5
Maintainers
A TierC++ 50.8k

nlohmann/json

JSON for Modern C++

57.8%
Merge Rate
-
First Review
55%
1st-Timers
40
Maintainers
A TierRust 135

anweiss/cddl

Concise data definition language (RFC 8610) implementation and JSON and CBOR validator in Rust

74.3%
Merge Rate
-
First Review
67%
1st-Timers
3
Maintainers
A TierKotlin 5.9k

Kotlin/kotlinx.serialization

Kotlin multiplatform / multi-format serialization

50.7%
Merge Rate
-
First Review
38%
1st-Timers
35
Maintainers
A TierC++ 855

danielaparker/jsoncons

A C++, header-only library for constructing JSON and JSON-like data formats, with JSON Pointer, JSON Patch, JSON Schema, JSONPath, JMESPath, CSV, MessagePack, CBOR, BSON, UBJSON, toon-format

85.2%
Merge Rate
12h
First Review
100%
1st-Timers
2
Maintainers
B TierScala 506

FasterXML/jackson-module-scala

Add-on module for Jackson (https://github.com/FasterXML/jackson) to support Scala-specific datatypes

54.5%
Merge Rate
-
First Review
100%
1st-Timers
1
Maintainers
B TierSwift 173

valpackett/SwiftCBOR

A CBOR implementation for Swift

100.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
B TierGo 1.1k

fxamacker/cbor

CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.

66.7%
Merge Rate
1d
First Review
0%
1st-Timers
2
Maintainers
B TierC++ 680

taocpp/json

C++ header-only JSON library

100.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
B TierGo 1.4k

rest-sh/restish

Restish is a CLI for interacting with REST-ish HTTP APIs with some nice features built-in

25.0%
Merge Rate
10d
First Review
33%
1st-Timers
2
Maintainers
B TierScala 165

gnieh/fs2-data

streaming data parsing and transformation library

44.4%
Merge Rate
-
First Review
0%
1st-Timers
2
Maintainers
C TierScala 242

sirthias/borer

Efficient CBOR and JSON (de)serialization in Scala

2.9%
Merge Rate
-
First Review
0%
1st-Timers
2
Maintainers
D TierC 347

Juniper/libxo

The libxo library allows an application to generate text, XML, JSON, and HTML output using a common set of function calls. The application decides at run time which output style should be produced.

0.0%
Merge Rate
8d
First Review
0%
1st-Timers
1
Maintainers
D TierC++ 1.4k

treefrogframework/treefrog-framework

TreeFrog Framework : High-speed C++ MVC Framework for Web Application

0.0%
Merge Rate
-
First Review
0%
1st-Timers
0
Maintainers
Best Cbor Open Source Repositories & C-Rank™ | GetMerged